Our Blog

Changes to default PHP Version

July 31st, 2015

closeThis post was published 4 years 22 days ago which means the content may no longer be applicable or relevant to the service we offer today. If in doubt, please contact us.

We are currently in the process of changing the default PHP version on all of our shared and semi-dedicated servers from PHP 5.3.29 to 5.5.27.

What does this mean for me?
Unless you have specifically selected your own PHP version within cPanel (more information on this later), your scripts (WordPress et all) will begin using this new version of PHP as soon as we have completed the change. No changes are necessary on your side, and this update will be automatically handled by our team.

We expect all of our servers to be updated to PHP 5.5.27 within the next 24 hours.

Will this change cause any problems for me?
Unfortunately we cannot say for sure. There are certainly differences between the PHP versions, and some functions may have been deprecated or removed entirely. If your script relies on and is using these functions, it may stop working altogether. If you do experience problems after this change, please continue reading this blog post as we will provide a potential solution further down.

If you are using a common and popular Open Source script such as WordPress, you are unlikely to be affected by these changes.

Why are we making this change?
PHP 5.3 went EOL (End of Life) in approximately the second quarter of 2014. This meant that no more security fixes were being added to PHP 5.3 as of the middle of 2014. PHP 5.4 will be EOL on 14th September 2015. Again, this means that no more security fixes will be rolled out after September this year.

In order to ensure our environments are as stable and secure as possible, we are making the choice that we will now maintain a default PHP version on all servers that is in active development. This means that going forward, when a version of PHP has entered its EOL period, we will replace it with the latest actively developed version.

Previously we continued to run with PHP 5.3.xx because we did not want to potentially interrupt existing customer websites with a new version of PHP before people have had a chance to upgrade to ensure compatibility. We have, for a very long time, provided the ability for our customers to choose which version of PHP they wanted to use from within their cPanel. This allowed customers who wanted to use a newer version the ability to bypass our default selection and choose their own, including selecting the modules they wished to use. Given how long it has been since PHP 5.3 went EOL, we now believe that enough time has passed that these scripts should now be fully compatible, and that it is in the best interests of server security that customers are using the most secure version of PHP available. We are skipping the upgrade from PHP 5.3 to PHP 5.4 because this is also due to go EOL within 2 months.

How do I roll back to/use PHP 5.3 (or earlier) if I need to?
We very strongly suggest that you use the native version of PHP on the server unless you are experiencing significant problems and/or your existing scripts are not supported. Running an older version of PHP potentially puts you and your account at risk and there really is no need to use an older version unless it is impossible for your script to be updated. That said, we provide the ability for all customers to choose the PHP version on their account from within cPanel. Please follow this knowledgebase article for details and instructions on how to accomplish this.

Conclusion
We do not expect this change to cause any significant problems or global issues, but we sincerely apologize for any inconvenience that this may cause you if you are one of the small number of people this might affect. Rest assured, we would not make such a change if we did not provide the ability for our customers to choose an older version of PHP if required in order to resolve any possible compatibility issues.

As always, if you have any questions, comments or concerns about this blog post, then please feel free to use the comments section below. If you have a specific question about the PHP on your account, please be sure to open a support ticket from our client area so we can identify you and your account.

Two Comments

  1. Anne Reid

    August 4, 2015

    Re: PHP scripts update.
    I rarely go to the Client Area. When do I read blogs?
    Our website has been down since 1st August because I wasn’t informed that PHP scripts update were required.
    Come on… this information should have been emailed out to clients.

  2. Douglas McGregor

    August 4, 2015

    Sorry to hear you are one of the few affected by this. We decided not to e-mail all of our customers because this is not an issue that will affect most. Only those with significantly out of date or otherwise non-maintained scripts are at all likely to be affected by this. If you have been having issues since the 1st of August I can only apologize and reiterate that we are more than happy to assist customers via support ticket. Customers who try and submit a support ticket will be greeted with the same information as our blog and will be notified of this change, so can take the appropriate action.

    I can see that you did submit a ticket and we responded very shortly thereafter advising of this change and which steps to follow to potentially resolve your problem. Additionally, I have asked Jules to roll back your version of PHP in order to solve this problem for you.

What do you think?